FORUM

Check out our Forum Rules. Lets keep this forum an enjoyable place to visit.

A A A
Avatar
Please consider registering
guest
sp_LogInOut Log In sp_Registration Register
Register | Lost password?
Advanced Search
Forum Scope




Match



Forum Options



Minimum search word length is 3 characters - maximum search word length is 84 characters
sp_Feed Topic RSS sp_TopicIcon
Says we can discuss anything here, so maybe someone can explain this to me
My iPhone will not send texts to some people. It seems to be adding a “1” to the front of the phone number in the send to box
Topic Rating: 0 Topic Rating: 0 Topic Rating: 0 Topic Rating: 0 Topic Rating: 0 Topic Rating: 0 (0 votes) 
Avatar
cid
Members

Regulars
March 9, 2019 - 5:29 pm
Member Since: December 26, 2018
Forum Posts: 954
sp_UserOfflineSmall Offline

I tried texting my brother-in-law about a month ago. It would not send. I got a message to enter a legitimate 10 digit number. It is a legitimate 10 digit number. It is from my contacts and I call him using that number. In the contacts listing, there is no 1.

Ex. In contacts: (123)456-7890

The send to box in the iMessages sends it to: 1(123)456-7890 It is now an 11 digit number. My brother-in-law lives down the street, same area code. I ended out calling him. The number is good.

Today I tried texting my brother in another state. The same exact thing happened. The phone put a number 1 in front of his correct number from my contacts. I tried manually entering the number. It changed it to his name, I could not skip that and leave the number as is and just go down and type my message. I had to select his name. The number 1 was added again. Got the message to resend with a legitimate 10 digit number. I called him. Later I texted to his email address. Not sure if that goes to his email, or actually shows up as a text. Hopefully, a text so he gets the message quickly. Who knows when he will check his email.

I never had this problem before. Has anyone else run across this?

I have a 6plus and use ATT.

I posted a message on an iphone forum, but no reply.

I have Googled. Here are two responses. I think one is from Apple’s community site, but not sure.

One answer said to constantly remove that contact, send the message and then put the contact back. Really? That is a solution? Remove a contact’s info before sending a text? Once I remove the contact, that info is gone, for one thing. If I wanted to manually write down the contact info, I would just address an envelope and stamp it. LOL Also, seems to me, the “1” would still be added.

One person said to use a different thread from that person and just continue it. I never texted my brother or brother-in-law before. There is no thread. How do you get the thread to begin with, anyway? 

Could this be an ATT thing that they automatically put this number 1 before all numbers? Why? I do not leave this country. If I need a passport, forget it. I lose too many things. Thag passport would be lost and I would be living in an airport (LOL). I know that when I call my brother, the 1 is added automatically. But, why is it now being added to a text message recipient’s number? I do not recall this happening before. I do not have a large circle of people I text. 99% are to my kids or husband (he keeps trying to get out of earshot, but the text messages still find him). Never had a problem with that.

They call me, “Mellow Cello” 

Avatar
Fiddlerman
Fort Lauderdale
March 10, 2019 - 10:10 pm
Member Since: September 26, 2010
Forum Posts: 14582

All I have to say is, "your brother has an extremely easy number to remember". ROFL.
Sorry, I do not have the answer to your question. Has never happened to me.

"The richest person is not the one who has the most,
but the one who needs the least."

Avatar
cid
Members

Regulars
March 11, 2019 - 7:29 am
Member Since: December 26, 2018
Forum Posts: 954
sp_UserOfflineSmall Offline

Yes, he does! Better than (555)555-5555. Has variety and you don’t have to count the number of 5’s.

They call me, “Mellow Cello” 

Avatar
Gordon Shumway
London, England
Honorary tenured advisor
Members

Regulars
March 11, 2019 - 7:48 am
Member Since: August 1, 2016
Forum Posts: 639
sp_UserOfflineSmall Offline

cid said
In the contacts listing, there is no 1.

Ex. In contacts: (123)456-7890

The send to box in the iMessages sends it to: 1(123)456-7890

Sorry, but this seems self-contradictory.

Have you tried putting this number in the contacts listing: 234567890?

Andrew

Avatar
cid
Members

Regulars
March 11, 2019 - 9:14 am
Member Since: December 26, 2018
Forum Posts: 954
sp_UserOfflineSmall Offline

Gordon Shumway said

cid said
In the contacts listing, there is no 1.

Ex. In contacts: (123)456-7890

The send to box in the iMessages sends it to: 1(123)456-7890

Sorry, but this seems self-contradictory.

Have you tried putting this number in the contacts listing: 234567890?  

@Gordon Shumway In my contacts, there is no number 1. I will use (234)567(8901) as the example number instead (123)456-7890. 

In my contacts, say John Buck. His number is listed in my contacts as:

(234)567)8901

When I go to messgaes and start to enter his name it gives the selections and you choose, John Buck. The “To” box shows, “John Buck”, and it is selected. Type the message and send the text. 

A second later I get a message saying the message would not send and it says to use a legitimate 10 digit phone number. It also shows the number that was used. It says I used 1(234)567-8901. The number 1 was added at the beginning by whatever is responsible for sending the message. The number is now an 11 digit number and will not send. That is not how it appears in my contacts, in my contacts it is (234)567-8901.

Now, I tried to just manually enter the phone number, I typed 234578901 and got options pop up. First one is John Buck. I tried to ignore all options and have it use what I typed in. Nope, had to choose. Could not just type the message and send with the number up above,

For some reason, either Messages or my carrier, ATT, is adding the 1 before all numbers when you call, I do recall that being started years and years ago. It is some code for area. Automatically is added so if you call, say another county that makes it a long distance call, or out of area,  you would normally have had to add the 1 before the number, you don’t do that anymore. It is done automatically. For some reason, it is also being added to text messages. Since Messages will only accept a 10 digit number (at least for texts in the US), it will not send the text because a “1” has been added to the number you are using.

I have been Googling this and found compaints from way back as far as 2015. Nobody has given an explanation as to how to prevent it. One person said to use another messenger. Sorry, but that is not a solution. I am not downloading another app, another app to have to keep updating, and another app to worry about security with. Probably another username and password requirement (which is not going to happen). 

This was not happening before, or I have never run into this circumstance that creates the issue.  Unfortunately, I can’t do any testing with the two numbers I know give me this issue. It is driving me nuts that I cannot find anyone with this issue. I bet if someone (US resident because I don’t know about international numbers) tried to text someone they have never ever texted before, an absolutely new contact with an absolutely new number, they would get this probelm. If they tried to manually enter the number and that contact was in their contacts, they would have to choose and the “1” would be added automatically. If they tried to send to someone not in their contacts, I suspect the number 1 would be added when it was sent, even though it is not typed in the “To” box.

From Googling, this is not just ATT. There are Verizon, Sprint, etc people finding this issue. But responses to the issue are not paying attention and telling them to switch carriers. Not a solution. 

I am going to call ATT later and see what I can find. Maybe it is an issue with them that they need to address whereby a number that is sending a text message does not get that “1” tacked on to the front of phone numbers?

It makes absolutely no sense. 

They call me, “Mellow Cello” 

Avatar
Fiddlerman
Fort Lauderdale
March 11, 2019 - 9:18 am
Member Since: September 26, 2010
Forum Posts: 14582

CID, do you have an iPhone?
I know that I had some issues with messages that are sent as an iMessage vs SMS.

You have obviously done a lot of research on the subject so my input isn't going to be worth much. As I mentioned, I have not had this issue as of yet. I did however have the issue of messages not getting sent because of a mistake on identifying the type of phone vs what message should be sent.

I did end up changing a setting on my iPhone that took care of the problem.

"The richest person is not the one who has the most,
but the one who needs the least."

Avatar
cid
Members

Regulars
March 11, 2019 - 9:25 am
Member Since: December 26, 2018
Forum Posts: 954
sp_UserOfflineSmall Offline

Sure is an iPhone. 6 plus. I tried on my husband’s iPhine (different model) and got the same thing. 

They call me, “Mellow Cello” 

Avatar
Amateur
Advanced member
Members
March 11, 2019 - 4:35 pm
Member Since: August 29, 2017
Forum Posts: 84
sp_UserOfflineSmall Offline

I doubt, though it's possible, that this is a hardware issue.

Whenever there's an issue with requiring area codes(or in your case country code!), it's usually a carrier-side issue. Sounds like you're already working on contacting the carrier.

I previously had an issue after moving to a new town where the phone wouldn't choose the closest cell tower and kept trying to utilize the further one whenever a call was made or received which resulted in many dropped calls. The staff at Verizon were stumped. After attempting all the software-side fixes, I did a factory reset of the phone and it suddenly worked. 

And they call these phones "smart".

Avatar
cid
Members

Regulars
March 11, 2019 - 5:20 pm
Member Since: December 26, 2018
Forum Posts: 954
sp_UserOfflineSmall Offline

@Amateur  said “I previously had an issue after moving to a new town where the phone wouldn't choose the closest cell tower and kept trying to utilize the further one whenever a call was made or received which resulted in many dropped calls. The staff at Verizon were stumped.”

When we got our first cell phone, mid to late 1990’s, here in the US there was still this thing back then about how many local talk hours were in your plan and how many long distance hours were included in your plan. You paid extra if you went over the talk hours in your plan.

With that in mind, here was my issue with Verizon back then. If I called from inside my house to anywhere local, it was a local call. If I went outside in my driveway or yard, it all of a sudden was considered a long distance call to the same people who are local. If I called a family member from inside my house, local. If I was outside, it was long distance. No WiFi was involved at this time, it is all cellular. 

I called Verizon and they said it was not possible. I had to be calling long distance. I told them that I had not traveled out of my town, there should be no long distance use showing up on my bill. I was in my driveway when I called so and so. I stood in my driveway and saw it change and indicate a long distance call. I showed them my bill the next month. I did a test. I made calls from inside (they are timestamped). I immediately went outside and made the same call. If I recall, I did it about 5 times to the same person, inside and out. I showed the people at our local Verizon. I told them that there was no way that in leas than a minute I can travel to make this same person be a long distance call, and then local again. Probably not even if Scotty beamed me. I was told that it must be a tower issue, to which I told them to fix it. I cannot remember exactly how that issue was rectified. I just remember that very odd issue of being local inside and long distance outside back in the mid to late 1990’s.

The talk time did not matter either way because we never even maxed out talk time, but the fact was that there was an issue that could have bitten us in the butt later.

Isn’t that really weird? If I remember, after that contract was up, that was when we switched to ATT. Those were the days when phones were used for phone calls and you paid for the phone call use. Flip tops, simple little phones. 

They call me, “Mellow Cello” 

Avatar
Bob
Members

Regulars
March 11, 2019 - 8:39 pm
Member Since: July 13, 2017
Forum Posts: 232
sp_UserOfflineSmall Offline
10sp_Permalink sp_Print
0

I'm beginning to feel lucky that I have no cell phone coverage in my rural area 🙂 Too many horror stories. I'm am lucky to have DSL (took 20 year to get here though).

Thanks for the description of your issues @cid. 

Bob in Lone Oak, Texas

Avatar
Fiddlerman
Fort Lauderdale
March 12, 2019 - 10:59 am
Member Since: September 26, 2010
Forum Posts: 14582
11sp_Permalink sp_Print
0

Personally, I never enter the 1 before the area code and it turns out that this works fine.

"The richest person is not the one who has the most,
but the one who needs the least."

Avatar
damfino
my own little world
Members

Regulars
March 12, 2019 - 11:13 am
Member Since: July 23, 2015
Forum Posts: 1933
sp_UserOfflineSmall Offline
12sp_Permalink sp_Print
0

For me, I default enter the #1 before all my contacts because we have so many area codes locally, it just became a habit, even if they are in my area code. I've never had an issue? Usually around here it gets mad at me if I don't have the #1.

☆•*¨*•¸¸¸.•*¨*•☆•*¨*•¸¸¸.•*¨*•☆•*¨*•.¸¸¸.•*¨*•☆
World's Okayest Fiddler
☆•*¨*•.¸¸¸.•*¨* •☆•*¨*¨*•¸¸¸.•*¨*•☆

Avatar
Fiddlerman
Fort Lauderdale
March 12, 2019 - 11:25 am
Member Since: September 26, 2010
Forum Posts: 14582
13sp_Permalink sp_Print
0

LOL. The opposite and that works for her....HMMMM, even more confusing!

"The richest person is not the one who has the most,
but the one who needs the least."

Avatar
cid
Members

Regulars
March 12, 2019 - 12:30 pm
Member Since: December 26, 2018
Forum Posts: 954
sp_UserOfflineSmall Offline
14sp_Permalink sp_Print
0

Well, actually, in the US, you don’t have to anymore, add the 1. Quite a few years ago, because of all the cell phone numbers starting in one area and people moving with them to another area, the 1 started being tacked on automatically. I think that is causing the issue that started this thread. The message I get back stating I need a real 10 digit number and try again shows the number I texted to. That number has the 1 tacked to the front. In my contacts, where that number comes from, does not have the number 1. There was a big todo about it in the news how people no longer have to know if they need a 1 or not. Remember that? At least 10’years ago, I believe. Up until that time, to call any of my family on the other side of the lake, where I grew up, I had to add the 1. 

Either Apple has to allow for 10 or 11 digit numbers when texting, or the phone companies need to differentiate from a phone number being used for a phone call or a text, and act accordingly. A simple “if” and “then” statement should suffice. For now, I am using an email address instead of the phone numbers that give me issues. That should work because the phone number is not used.

They call me, “Mellow Cello” 

Avatar
Fiddlerman
Fort Lauderdale
March 14, 2019 - 3:01 pm
Member Since: September 26, 2010
Forum Posts: 14582
15sp_Permalink sp_Print
0

Are you still having the issue?

"The richest person is not the one who has the most,
but the one who needs the least."

Avatar
cid
Members

Regulars
March 14, 2019 - 5:33 pm
Member Since: December 26, 2018
Forum Posts: 954
sp_UserOfflineSmall Offline
16sp_Permalink sp_Print
0

@Fiddlerman Not sure if it is still an issue. I texted my two daughters today, but they each have iPhones and it uses information from previous texrs for that contact. Never had an issue with them. I texted my sister, and she got it, no iPhone at her end. I wonder if it was a temporary software glitch with ATT? I never got around to calling them. I have been really busy.

They call me, “Mellow Cello” 

Avatar
Fiddlerman
Fort Lauderdale
March 18, 2019 - 1:02 pm
Member Since: September 26, 2010
Forum Posts: 14582
17sp_Permalink sp_Print
0

Hopefully it was temporary. I also remember issues being based on whether or not I had wifi on but I haven't had that in a while.

"The richest person is not the one who has the most,
but the one who needs the least."

Forum Timezone: America/New_York
Most Users Ever Online: 424
Currently Online: Jim Dunleavy, wtw
145
Guest(s)
Currently Browsing this Page:
1 Guest(s)
Members Birthdays
sp_BirthdayIcon
Today None
Upcoming Killerkhezu, Ferret, HDuaneaz, vibaviattigala, BillyG, rsmith6322, zpilot, Rafael Gonzales, ACDSherlockian, NiloiV, jose6ph, Kody
Top Posters:
Mad_Wed: 2849
Barry: 2673
Fiddlestix: 2647
Oliver: 2439
DanielB: 2379
Kevin M.: 1969
damfino: 1933
cdennyb: 1814
TerryT: 1726
Ferret: 1575
Member Stats:
Guest Posters: 3
Members: 25780
Moderators: 0
Admins: 8
Forum Stats:
Groups: 16
Forums: 58
Topics: 7974
Posts: 99388
Newest Members:
pbyefchuryic, Voodoojarchuryic, ybyjfchuryic, ktjynmbxchuryic, maximianichchuryic, Acebiolanechuryic
Administrators: Fiddlerman: 14582, KindaScratchy: 1737, coolpinkone: 4169, BillyG: 2963, MrsFiddlerman: 1, Jimmie Bjorling: 0, SimplePressHelp: 0, peopleshost: 0